aboutsummaryrefslogtreecommitdiff
path: root/nixos/variables.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/variables.nix')
-rw-r--r--nixos/variables.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/nixos/variables.nix b/nixos/variables.nix
new file mode 100644
index 0000000..e6b111d
--- /dev/null
+++ b/nixos/variables.nix
@@ -0,0 +1,15 @@
+{config, pkgs, lib, ...}:
+{
+
+ # Type definitions for nix variables used in this configuration
+ options = with lib; with types; {
+ myUserName = mkOption { type = str; };
+ myHostName = mkOption { type = str; };
+ };
+
+ # Default values for this configuration
+ config = {
+ myUserName = "stvnliu";
+ myHostName = "homelab-nix";
+ };
+}