aboutsummaryrefslogtreecommitdiff
path: root/nixos/variables.nix
diff options
context:
space:
mode:
authorZhongheng Liu <z.liu@outlook.com.gr>2024-07-31 14:46:59 +0000
committerZhongheng Liu <z.liu@outlook.com.gr>2024-07-31 14:46:59 +0000
commit0770a70d0bb4899cc2496662482ec20b0b6588c5 (patch)
treee59f42c5645549f093be111fbb1b83f492b45690 /nixos/variables.nix
parent8fecc5f5924c9a56ee4ee034d74cd8af3efd5fee (diff)
downloadnixos-configuration-0770a70d0bb4899cc2496662482ec20b0b6588c5.tar.gz
nixos-configuration-0770a70d0bb4899cc2496662482ec20b0b6588c5.tar.bz2
nixos-configuration-0770a70d0bb4899cc2496662482ec20b0b6588c5.zip
feat: created variable-based nix configuration
Added variables.nix Added Syncthing service definition
Diffstat (limited to 'nixos/variables.nix')
-rw-r--r--nixos/variables.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/nixos/variables.nix b/nixos/variables.nix
new file mode 100644
index 0000000..e6b111d
--- /dev/null
+++ b/nixos/variables.nix
@@ -0,0 +1,15 @@
+{config, pkgs, lib, ...}:
+{
+
+ # Type definitions for nix variables used in this configuration
+ options = with lib; with types; {
+ myUserName = mkOption { type = str; };
+ myHostName = mkOption { type = str; };
+ };
+
+ # Default values for this configuration
+ config = {
+ myUserName = "stvnliu";
+ myHostName = "homelab-nix";
+ };
+}