aboutsummaryrefslogtreecommitdiff
path: root/nixos/custom-hosts.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/custom-hosts.nix')
-rw-r--r--nixos/custom-hosts.nix19
1 files changed, 14 insertions, 5 deletions
diff --git a/nixos/custom-hosts.nix b/nixos/custom-hosts.nix
index 69dcbc6..495adb4 100644
--- a/nixos/custom-hosts.nix
+++ b/nixos/custom-hosts.nix
@@ -1,9 +1,18 @@
{ ...
-}: {
+}:
+let
+ rootDomainName = "stvnliu.me";
+ subdomains = [
+ "git"
+ "kellnr"
+ "www"
+ "blog"
+ "files"
+ ];
+in
+{
networking.extraHosts = ''
- # home IP mapping
-
- 192.168.2.1 router.home
- 192.168.2.2 server.home
+ # home IP mapping
+ 100.91.33.34 ${rootDomainName} ${builtins.concatStringsSep " " (map (x: x + "." + rootDomainName) subdomains)}
'';
}