aboutsummaryrefslogtreecommitdiff
path: root/nixos/custom-hosts.nix
diff options
context:
space:
mode:
authorZhongheng Liu <z.liu@outlook.com.gr>2025-02-07 18:18:23 +0200
committerZhongheng Liu <z.liu@outlook.com.gr>2025-02-07 18:18:23 +0200
commitbb120b4e3d7c312d4b1c6303104cf06604e62d3d (patch)
tree8e87d2b1eacc041f6f2e40a3965e260c068c26fe /nixos/custom-hosts.nix
parentdb83134e6b46f189a4bf002637363fe4cd501c7a (diff)
downloadnixos-configuration-bb120b4e3d7c312d4b1c6303104cf06604e62d3d.tar.gz
nixos-configuration-bb120b4e3d7c312d4b1c6303104cf06604e62d3d.tar.bz2
nixos-configuration-bb120b4e3d7c312d4b1c6303104cf06604e62d3d.zip
feat: a bunch of misc updates
Diffstat (limited to 'nixos/custom-hosts.nix')
-rw-r--r--nixos/custom-hosts.nix19
1 files changed, 14 insertions, 5 deletions
diff --git a/nixos/custom-hosts.nix b/nixos/custom-hosts.nix
index 69dcbc6..495adb4 100644
--- a/nixos/custom-hosts.nix
+++ b/nixos/custom-hosts.nix
@@ -1,9 +1,18 @@
{ ...
-}: {
+}:
+let
+ rootDomainName = "stvnliu.me";
+ subdomains = [
+ "git"
+ "kellnr"
+ "www"
+ "blog"
+ "files"
+ ];
+in
+{
networking.extraHosts = ''
- # home IP mapping
-
- 192.168.2.1 router.home
- 192.168.2.2 server.home
+ # home IP mapping
+ 100.91.33.34 ${rootDomainName} ${builtins.concatStringsSep " " (map (x: x + "." + rootDomainName) subdomains)}
'';
}