aboutsummaryrefslogtreecommitdiff
path: root/devenv.nix
diff options
context:
space:
mode:
authorZhongheng Liu <z.liu@outlook.com.gr>2025-03-15 20:54:50 +0200
committerZhongheng Liu <z.liu@outlook.com.gr>2025-03-15 20:54:50 +0200
commit6fba7b70a5f9583dfca6a3df15d7f6d0c46dae39 (patch)
tree9d1104ae8dd69167bf031b4ca17695e728b32c16 /devenv.nix
downloadhello_test-master.tar.gz
hello_test-master.tar.bz2
hello_test-master.zip
feat: init projectHEADmaster
Diffstat (limited to 'devenv.nix')
-rw-r--r--devenv.nix45
1 files changed, 45 insertions, 0 deletions
diff --git a/devenv.nix b/devenv.nix
new file mode 100644
index 0000000..eaff758
--- /dev/null
+++ b/devenv.nix
@@ -0,0 +1,45 @@
+{ pkgs, lib, config, inputs, ... }:
+
+{
+ # https://devenv.sh/basics/
+ env.GREET = "devenv";
+
+ # https://devenv.sh/packages/
+ packages = [ pkgs.git ];
+
+ # https://devenv.sh/languages/
+ # languages.rust.enable = true;
+
+ # https://devenv.sh/processes/
+ # processes.cargo-watch.exec = "cargo-watch";
+
+ # https://devenv.sh/services/
+ # services.postgres.enable = true;
+
+ # https://devenv.sh/scripts/
+ scripts.hello.exec = ''
+ echo hello from $GREET
+ '';
+
+ enterShell = ''
+ hello
+ git --version
+ '';
+
+ # https://devenv.sh/tasks/
+ # tasks = {
+ # "myproj:setup".exec = "mytool build";
+ # "devenv:enterShell".after = [ "myproj:setup" ];
+ # };
+
+ # https://devenv.sh/tests/
+ enterTest = ''
+ echo "Running tests"
+ git --version | grep --color=auto "${pkgs.git.version}"
+ '';
+
+ # https://devenv.sh/git-hooks/
+ # git-hooks.hooks.shellcheck.enable = true;
+
+ # See full reference at https://devenv.sh/reference/options/
+}