aboutsummaryrefslogtreecommitdiff
path: root/nixos/spec.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/spec.nix')
-rw-r--r--nixos/spec.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/nixos/spec.nix b/nixos/spec.nix
new file mode 100644
index 0000000..77ac310
--- /dev/null
+++ b/nixos/spec.nix
@@ -0,0 +1,25 @@
+{ config, pkgs, lib, ... }: {
+ specialisation = {
+ wayland = {
+ configuration = {
+ programs = {
+ hyprland = {
+ enable = true; # enables Hyprland DM.
+ withUWSM = true; # NEW Universal Wayland Session Manager
+ };
+ };
+ };
+ };
+ xorg = {
+ configuration = lib.recursiveUpdate
+ {
+ services.xserver.displayManager.startx.enable = true;
+ }
+ (import ./dwm {
+ inherit config;
+ inherit pkgs;
+ inherit lib;
+ });
+ };
+ };
+}