aboutsummaryrefslogtreecommitdiff
path: root/nixos/nvidia.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/nvidia.nix')
-rw-r--r--nixos/nvidia.nix13
1 files changed, 6 insertions, 7 deletions
diff --git a/nixos/nvidia.nix b/nixos/nvidia.nix
index e28d41e..bb2f679 100644
--- a/nixos/nvidia.nix
+++ b/nixos/nvidia.nix
@@ -1,8 +1,7 @@
-{
- config,
- lib,
- pkgs,
- ...
+{ config
+, lib
+, pkgs
+, ...
}: {
specialisation = {
powersave.configuration = {
@@ -15,14 +14,14 @@
};
};
};
- boot.kernelModules = ["nvidia_uvm"];
+ boot.kernelModules = [ "nvidia_uvm" ];
hardware.graphics = {
enable = true;
extraPackages = with pkgs; [
libvdpau-va-gl
];
};
- services.xserver.videoDrivers = ["nvidia"];
+ services.xserver.videoDrivers = [ "nvidia" ];
hardware.nvidia = {
dynamicBoost.enable = true;
prime = {