aboutsummaryrefslogtreecommitdiff
path: root/nixos/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/hardware-configuration.nix')
-rw-r--r--nixos/hardware-configuration.nix23
1 files changed, 11 insertions, 12 deletions
diff --git a/nixos/hardware-configuration.nix b/nixos/hardware-configuration.nix
index 020471e..1dc6755 100644
--- a/nixos/hardware-configuration.nix
+++ b/nixos/hardware-configuration.nix
@@ -1,21 +1,20 @@
# Do not modify this file! It was generated by ‘nixos-generate-config’
# and may be overwritten by future invocations. Please make changes
# to /etc/nixos/configuration.nix instead.
-{
- config,
- lib,
- pkgs,
- modulesPath,
- ...
+{ config
+, lib
+, pkgs
+, modulesPath
+, ...
}: {
imports = [
(modulesPath + "/installer/scan/not-detected.nix")
];
- boot.initrd.availableKernelModules = ["nvme" "xhci_pci" "usbhid"];
- boot.initrd.kernelModules = [];
- boot.kernelModules = ["kvm-amd"];
- boot.extraModulePackages = [];
+ boot.initrd.availableKernelModules = [ "nvme" "xhci_pci" "usbhid" ];
+ boot.initrd.kernelModules = [ ];
+ boot.kernelModules = [ "kvm-amd" ];
+ boot.extraModulePackages = [ ];
fileSystems."/" = {
device = "/dev/disk/by-uuid/f9ff609f-6e72-43cf-917c-3bd3fde6c410";
@@ -25,7 +24,7 @@
fileSystems."/boot" = {
device = "/dev/disk/by-uuid/2E4F-3060";
fsType = "vfat";
- options = ["fmask=0022" "dmask=0022"];
+ options = [ "fmask=0022" "dmask=0022" ];
};
fileSystems."/games" = {
@@ -33,7 +32,7 @@
fsType = "ext4";
};
- swapDevices = [];
+ swapDevices = [ ];
# Enables DHCP on each ethernet and wireless interface. In case of scripted networking
# (the default) this is the recommended approach. When using systemd-networkd it's