aboutsummaryrefslogtreecommitdiff
path: root/nixos/greetd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/greetd.nix')
-rw-r--r--nixos/greetd.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/nixos/greetd.nix b/nixos/greetd.nix
new file mode 100644
index 0000000..212cde7
--- /dev/null
+++ b/nixos/greetd.nix
@@ -0,0 +1,33 @@
+{
+ pkgs,
+ config,
+ lib,
+ ...
+}: let
+ tuigreet = "${pkgs.greetd.tuigreet}/bin/tuigreet";
+in {
+ services.greetd = {
+ enable = true;
+ settings = {
+ default_session = {
+ command = "${tuigreet} --time --remember --cmd Hyprland";
+ user = "greeter";
+ };
+ };
+ };
+
+ # this is a life saver.
+ # literally no documentation about this anywhere.
+ # might be good to write about this...
+ # https://www.reddit.com/r/NixOS/comments/u0cdpi/tuigreet_with_xmonad_how/
+ systemd.services.greetd.serviceConfig = {
+ Type = "idle";
+ StandardInput = "tty";
+ StandardOutput = "tty";
+ StandardError = "journal"; # Without this errors will spam on screen
+ # Without these bootlogs will spam on screen
+ TTYReset = true;
+ TTYVHangup = true;
+ TTYVTDisallocate = true;
+ };
+}