aboutsummaryrefslogtreecommitdiff
path: root/nixos/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/configuration.nix')
-rw-r--r--nixos/configuration.nix22
1 files changed, 11 insertions, 11 deletions
diff --git a/nixos/configuration.nix b/nixos/configuration.nix
index bbcc3f8..2690c28 100644
--- a/nixos/configuration.nix
+++ b/nixos/configuration.nix
@@ -8,15 +8,11 @@
...
}:
let
-myHostName = "homelab-nix";
-stevenUserName = "stvnliu";
+ globals = import ./globals.nix;
in
{
imports = [
-#inputs.hardware.nixosModules.common-cpu-amd
-#inputs.hardware.nixosModules.common-ssd
./hardware-configuration.nix
- ./services/display-manager.nix
];
boot.loader = {
efi.canTouchEfiVariables = true;
@@ -36,6 +32,12 @@ in
'';
};
};
+ security.polkit.enable = true;
+ services.gnome.gnome-keyring.enable = true;
+ programs.sway = {
+ enable = true;
+ wrapperFeatures.gtk = true;
+ };
nixpkgs = {
overlays = [
];
@@ -56,20 +58,18 @@ in
nixPath = lib.mapAttrsToList (n: _: "${n}=flake:${n}") flakeInputs;
};
networking = {
- hostName = "${myHostName}";
+ hostName = "${globals.myHostName}";
networkmanager.enable = true;
};
users.users = {
- "${stevenUserName}" = {
+ "${globals.myUserName}" = {
initialPassword = "stevenpassword";
isNormalUser = true;
openssh.authorizedKeys.keys = [
];
packages = with pkgs; [
- nh
- neovim
- gitFull
- ];
+ nh
+ ];
extraGroups = ["wheel"];
};
};