aboutsummaryrefslogtreecommitdiff
path: root/nixos/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/configuration.nix')
-rw-r--r--nixos/configuration.nix11
1 files changed, 7 insertions, 4 deletions
diff --git a/nixos/configuration.nix b/nixos/configuration.nix
index 7de01f9..1639b76 100644
--- a/nixos/configuration.nix
+++ b/nixos/configuration.nix
@@ -22,9 +22,14 @@
FLAKE = config.myConfigLocation;
GTK_IM_MODULE = lib.mkForce "";
};
+ programs.gamescope = {
+ enable = true;
+ capSysNice = true;
+ };
security.pam.services.hyprlock = {};
i18n.inputMethod = {
- enabled = "fcitx5";
+ type = "fcitx5";
+ enable = true;
fcitx5.addons = with pkgs; [
fcitx5-mozc
fcitx5-gtk
@@ -65,9 +70,7 @@
true; # Open ports in the firewall for Source Dedicated Server
localNetworkGameTransfers.openFirewall =
true; # Open ports in the firewall for Steam Local Network Game Transfers
- gamescopeSession = {
- enable = true;
- };
+ extraCompatPackages = with pkgs; [proton-ge-bin];
};
programs.gamemode.enable = true;
boot = {