aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix81
1 files changed, 42 insertions, 39 deletions
diff --git a/flake.nix b/flake.nix
index dcc6fce..43c2c20 100644
--- a/flake.nix
+++ b/flake.nix
@@ -16,57 +16,60 @@
inputs.nixpkgs.follows = "nixpkgs";
};
/*
- lix-module = {
+ lix-module = {
url =
"https://git.lix.systems/lix-project/nixos-module/archive/2.91.0.tar.gz";
inputs.nixpkgs.follows = "nixpkgs";
- };
+ };
*/
- stylix = {url = "github:danth/stylix";};
+ stylix = { url = "github:danth/stylix"; };
spicetify-nix = {
url = "github:Gerg-L/spicetify-nix";
inputs.nixpkgs.follows = "nixpkgs";
};
+ hyprland-qtutils.url = "github:hyprwm/hyprland-qtutils";
};
- outputs = {
- self,
- nixpkgs,
- home-manager,
- stylix,
- spicetify-nix,
- ...
- } @ inputs: let
- inherit (self) outputs;
- myHostName = "nixos-msi";
- stevenUserName = "stvnliu";
- in {
- # NixOS configuration entrypoint
- # Available through 'nixos-rebuild --flake .#your-hostname'
- nixosConfigurations = {
- "${myHostName}" = nixpkgs.lib.nixosSystem {
- specialArgs = {inherit inputs outputs;};
- modules = [
- ./nixos/configuration.nix
- #lix-module.nixosModules.default
- ];
+ outputs =
+ { self
+ , nixpkgs
+ , home-manager
+ , stylix
+ , spicetify-nix
+ , ...
+ } @ inputs:
+ let
+ inherit (self) outputs;
+ myHostName = "nixos-msi";
+ stevenUserName = "stvnliu";
+ in
+ {
+ # NixOS configuration entrypoint
+ # Available through 'nixos-rebuild --flake .#your-hostname'
+ nixosConfigurations = {
+ "${myHostName}" = nixpkgs.lib.nixosSystem {
+ specialArgs = { inherit inputs outputs; };
+ modules = [
+ ./nixos/configuration.nix
+ #lix-module.nixosModules.default
+ ];
+ };
};
- };
- # Standalone home-manager configuration entrypoint
- # Available through 'home-manager --flake .#your-username@your-hostname'
- homeConfigurations = {
- "${stevenUserName}@${myHostName}" = home-manager.lib.homeManagerConfiguration {
- pkgs =
- nixpkgs.legacyPackages.x86_64-linux; # Home-manager requires 'pkgs' instance
- extraSpecialArgs = {inherit inputs outputs;};
- modules = [
- ./home-manager/${stevenUserName}/home.nix
- inputs.nixvim.homeManagerModules.nixvim
- stylix.homeManagerModules.stylix
- spicetify-nix.homeManagerModules.default
- ];
+ # Standalone home-manager configuration entrypoint
+ # Available through 'home-manager --flake .#your-username@your-hostname'
+ homeConfigurations = {
+ "${stevenUserName}@${myHostName}" = home-manager.lib.homeManagerConfiguration {
+ pkgs =
+ nixpkgs.legacyPackages.x86_64-linux; # Home-manager requires 'pkgs' instance
+ extraSpecialArgs = { inherit inputs outputs; };
+ modules = [
+ ./home-manager/${stevenUserName}/home.nix
+ stylix.homeManagerModules.stylix
+ inputs.nixvim.homeManagerModules.nixvim
+ spicetify-nix.homeManagerModules.default
+ ];
+ };
};
};
- };
}