aboutsummaryrefslogtreecommitdiff
path: root/nixos/services/display-manager.nix
diff options
context:
space:
mode:
authorZhongheng Liu <z.liu@outlook.com.gr>2024-07-31 07:45:22 +0000
committerZhongheng Liu <z.liu@outlook.com.gr>2024-07-31 07:45:22 +0000
commitf10f6922fb9ea8b2535e97549a92cdf2d5cee08e (patch)
treee2f693624661cd59efb9bc7d279633cf5e40ffae /nixos/services/display-manager.nix
downloadnixos-configuration-f10f6922fb9ea8b2535e97549a92cdf2d5cee08e.tar.gz
nixos-configuration-f10f6922fb9ea8b2535e97549a92cdf2d5cee08e.tar.bz2
nixos-configuration-f10f6922fb9ea8b2535e97549a92cdf2d5cee08e.zip
feat: init config
Diffstat (limited to 'nixos/services/display-manager.nix')
-rw-r--r--nixos/services/display-manager.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/nixos/services/display-manager.nix b/nixos/services/display-manager.nix
new file mode 100644
index 0000000..edbd360
--- /dev/null
+++ b/nixos/services/display-manager.nix
@@ -0,0 +1,11 @@
+{ pkgs, lib, ... }:
+{
+ programs.sway = {
+ enable = true;
+ wrapperFeatures.gtk = true;
+ };
+ services.displayManager = {
+ enable = true;
+ execCmd = "${pkgs.lemurs}/bin/lemurs --no-logs";
+ };
+}