aboutsummaryrefslogtreecommitdiff
path: root/nixos/nvidia.nix
diff options
context:
space:
mode:
authorZhongheng Liu <z.liu@outlook.com.gr>2025-02-26 13:53:41 +0200
committerZhongheng Liu <z.liu@outlook.com.gr>2025-02-26 13:53:41 +0200
commit19e72eedb7a4b447e3574b39c74e097417fbe91e (patch)
tree0209c6e40b4707dd989ddcdae2e0a5119ad4a44a /nixos/nvidia.nix
parent00f5075f174b5c941dff095560d19c1580e74b70 (diff)
downloadnixos-configuration-19e72eedb7a4b447e3574b39c74e097417fbe91e.tar.gz
nixos-configuration-19e72eedb7a4b447e3574b39c74e097417fbe91e.tar.bz2
nixos-configuration-19e72eedb7a4b447e3574b39c74e097417fbe91e.zip
feat: redesign, with onedark theme
Diffstat (limited to 'nixos/nvidia.nix')
-rw-r--r--nixos/nvidia.nix23
1 files changed, 11 insertions, 12 deletions
diff --git a/nixos/nvidia.nix b/nixos/nvidia.nix
index bb2f679..fa603e5 100644
--- a/nixos/nvidia.nix
+++ b/nixos/nvidia.nix
@@ -1,19 +1,18 @@
{ config
-, lib
, pkgs
, ...
}: {
- specialisation = {
- powersave.configuration = {
- hardware.nvidia.prime = {
- offload = {
- enable = lib.mkForce true;
- enableOffloadCmd = lib.mkForce true;
- };
- sync.enable = lib.mkForce false;
- };
- };
- };
+ #specialisation = {
+ # powersave.configuration = {
+ # hardware.nvidia.prime = {
+ # offload = {
+ # enable = lib.mkForce true;
+ # enableOffloadCmd = lib.mkForce true;
+ # };
+ # sync.enable = lib.mkForce false;
+ # };
+ # };
+ #};
boot.kernelModules = [ "nvidia_uvm" ];
hardware.graphics = {
enable = true;