aboutsummaryrefslogtreecommitdiff
path: root/nixos/hardware-configuration.nix
diff options
context:
space:
mode:
authorZhongheng Liu <z.liu@outlook.com.gr>2024-08-09 18:26:26 +0800
committerZhongheng Liu <z.liu@outlook.com.gr>2024-08-09 18:26:26 +0800
commit6d14dac99165360c241eb3cca5536cfa1aca71e8 (patch)
tree002853580592d7a8b1cc6b1161ac32618aad1e20 /nixos/hardware-configuration.nix
parent9e44996afdfa967accf5b98ed4f93258fc58a4df (diff)
downloadnixos-configuration-6d14dac99165360c241eb3cca5536cfa1aca71e8.tar.gz
nixos-configuration-6d14dac99165360c241eb3cca5536cfa1aca71e8.tar.bz2
nixos-configuration-6d14dac99165360c241eb3cca5536cfa1aca71e8.zip
feat(hyprland): added input options for reduced repeat_delay and increased repeat_speed
Diffstat (limited to 'nixos/hardware-configuration.nix')
-rw-r--r--nixos/hardware-configuration.nix42
1 files changed, 23 insertions, 19 deletions
diff --git a/nixos/hardware-configuration.nix b/nixos/hardware-configuration.nix
index b18ecf7..81b97e4 100644
--- a/nixos/hardware-configuration.nix
+++ b/nixos/hardware-configuration.nix
@@ -1,30 +1,34 @@
# Do not modify this file! It was generated by ‘nixos-generate-config’
# and may be overwritten by future invocations. Please make changes
# to /etc/nixos/configuration.nix instead.
-{ config, lib, pkgs, modulesPath, ... }:
-
{
- imports =
- [ (modulesPath + "/installer/scan/not-detected.nix")
- ];
+ config,
+ lib,
+ pkgs,
+ modulesPath,
+ ...
+}: {
+ imports = [
+ (modulesPath + "/installer/scan/not-detected.nix")
+ ];
- boot.initrd.availableKernelModules = [ "nvme" "xhci_pci" "usb_storage" "usbhid" "sd_mod" ];
- boot.initrd.kernelModules = [ ];
- boot.kernelModules = [ "kvm-amd" ];
- boot.extraModulePackages = [ ];
+ boot.initrd.availableKernelModules = ["nvme" "xhci_pci" "usb_storage" "usbhid" "sd_mod"];
+ boot.initrd.kernelModules = [];
+ boot.kernelModules = ["kvm-amd"];
+ boot.extraModulePackages = [];
- fileSystems."/" =
- { device = "/dev/disk/by-uuid/f9ff609f-6e72-43cf-917c-3bd3fde6c410";
- fsType = "ext4";
- };
+ fileSystems."/" = {
+ device = "/dev/disk/by-uuid/f9ff609f-6e72-43cf-917c-3bd3fde6c410";
+ fsType = "ext4";
+ };
- fileSystems."/boot" =
- { device = "/dev/disk/by-uuid/2E4F-3060";
- fsType = "vfat";
- options = [ "fmask=0022" "dmask=0022" ];
- };
+ fileSystems."/boot" = {
+ device = "/dev/disk/by-uuid/2E4F-3060";
+ fsType = "vfat";
+ options = ["fmask=0022" "dmask=0022"];
+ };
- swapDevices = [ ];
+ swapDevices = [];
# Enables DHCP on each ethernet and wireless interface. In case of scripted networking
# (the default) this is the recommended approach. When using systemd-networkd it's