aboutsummaryrefslogtreecommitdiff
path: root/nixos/grub.nix
diff options
context:
space:
mode:
authorZhongheng Liu <z.liu@outlook.com.gr>2024-08-20 11:18:51 +0800
committerZhongheng Liu <z.liu@outlook.com.gr>2024-08-20 11:18:51 +0800
commit3084dbcb7f1176fe4c0aaa05972e5b793b682ba3 (patch)
tree9d720cd38f16d449c230e1c197c3f100e2ff4266 /nixos/grub.nix
parent370669f99f4001072ee5819e76896fa7445d8674 (diff)
downloadnixos-configuration-3084dbcb7f1176fe4c0aaa05972e5b793b682ba3.tar.gz
nixos-configuration-3084dbcb7f1176fe4c0aaa05972e5b793b682ba3.tar.bz2
nixos-configuration-3084dbcb7f1176fe4c0aaa05972e5b793b682ba3.zip
feat: grub and greetd setups
grub: changed theme to distro-grub-themes kernel: upgraded to linux zen kernel greetd: configured tuigreet with greetd to replace sddm
Diffstat (limited to 'nixos/grub.nix')
-rw-r--r--nixos/grub.nix64
1 files changed, 64 insertions, 0 deletions
diff --git a/nixos/grub.nix b/nixos/grub.nix
new file mode 100644
index 0000000..5af6773
--- /dev/null
+++ b/nixos/grub.nix
@@ -0,0 +1,64 @@
+{
+ config,
+ pkgs,
+ ...
+}: let
+ distro-grub-themes = pkgs.stdenv.mkDerivation {
+ pname = "distro-grub-themes";
+ version = "3.1";
+ src = pkgs.fetchFromGitHub {
+ owner = "AdisonCavani";
+ repo = "distro-grub-themes";
+ rev = "v3.1";
+ hash = "sha256-ZcoGbbOMDDwjLhsvs77C7G7vINQnprdfI37a9ccrmPs=";
+ };
+ installPhase = "cp -r customize/nixos $out";
+ };
+ xenlism-grub-themes = pkgs.stdenv.mkDerivation {
+ pname = "xenlism-grub-themes";
+ version = "1.0";
+ src = pkgs.fetchFromGitHub {
+ owner = "xenlism";
+ repo = "Grub-themes";
+ rev = "40ac048df9aacfc053c515b97fcd24af1a06762f";
+ hash = "sha256-ProTKsFocIxWAFbYgQ46A+GVZ7mUHXxZrvdiPJqZJ6I=";
+ };
+ installPhase = "cp -r xenlism-grub-1080p-nixos/Xenlism-Nixos $out";
+ };
+in {
+ environment.systemPackages = with pkgs; [hack-font];
+ boot.supportedFilesystems = ["ntfs"];
+ #fileSystems."/mnt/winsys" = {
+ # device = "/dev/nvme0n1p5";
+ # fsType = "ntfs-3g";
+ # options = [ "rw" "uid=1000" ];
+ #};
+ #fileSystems."/mnt/windata" = {
+ # device = "/dev/nvme0n1p3";
+ # fsType = "ntfs-3g";
+ # options = [ "rw" "uid=1000" ];
+ #};
+ boot.loader = {
+ efi = {
+ canTouchEfiVariables = true;
+ };
+ grub = {
+ enable = true;
+ efiSupport = true;
+ device = "nodev";
+ fsIdentifier = "label";
+ devices = ["nodev"];
+ extraEntries = ''
+ menuentry "Reboot" {
+ reboot
+ }
+ menuentry "Poweroff" {
+ halt
+ }
+ '';
+ useOSProber = true;
+ configurationLimit = 10;
+ theme = xenlism-grub-themes;
+ };
+ };
+}