aboutsummaryrefslogtreecommitdiff
path: root/nixos/configuration.nix
diff options
context:
space:
mode:
authorZhongheng Liu <z.liu@outlook.com.gr>2024-10-06 11:00:48 +0300
committerZhongheng Liu <z.liu@outlook.com.gr>2024-10-06 11:00:48 +0300
commit9975cd7d64587b349fc4f6825c197da9b74823e4 (patch)
treedf9ac4dd0985355f239c60d520750e05e1fca38e /nixos/configuration.nix
parent1c5f8de4128f2bd40cfb7e1819245ded786f6453 (diff)
downloadnixos-configuration-9975cd7d64587b349fc4f6825c197da9b74823e4.tar.gz
nixos-configuration-9975cd7d64587b349fc4f6825c197da9b74823e4.tar.bz2
nixos-configuration-9975cd7d64587b349fc4f6825c197da9b74823e4.zip
chore: fmt and bump lock
Diffstat (limited to 'nixos/configuration.nix')
-rw-r--r--nixos/configuration.nix32
1 files changed, 17 insertions, 15 deletions
diff --git a/nixos/configuration.nix b/nixos/configuration.nix
index 1639b76..57b5b02 100644
--- a/nixos/configuration.nix
+++ b/nixos/configuration.nix
@@ -62,17 +62,20 @@
wantedBy = ["default.target"];
serviceConfig.ExecStart = "${pkgs.bluez}/bin/mpris-proxy";
};
- programs.steam = {
- enable = true;
- remotePlay.openFirewall =
- true; # Open ports in the firewall for Steam Remote Play
- dedicatedServer.openFirewall =
- true; # Open ports in the firewall for Source Dedicated Server
- localNetworkGameTransfers.openFirewall =
- true; # Open ports in the firewall for Steam Local Network Game Transfers
- extraCompatPackages = with pkgs; [proton-ge-bin];
+ programs = {
+ hyprland.enable = true; # enables Hyprland DM.
+ steam = {
+ enable = true;
+ remotePlay.openFirewall =
+ true; # Open ports in the firewall for Steam Remote Play
+ dedicatedServer.openFirewall =
+ true; # Open ports in the firewall for Source Dedicated Server
+ localNetworkGameTransfers.openFirewall =
+ true; # Open ports in the firewall for Steam Local Network Game Transfers
+ extraCompatPackages = with pkgs; [proton-ge-bin];
+ };
+ gamemode.enable = true;
};
- programs.gamemode.enable = true;
boot = {
kernelPackages = pkgs.linuxPackages_zen;
supportedFilesystems = ["ntfs"];
@@ -106,7 +109,6 @@
# enable = true;
# wrapperFeatures.gtk = true;
#};
- programs.hyprland.enable = true; # enables Hyprland DM.
nixpkgs = {
overlays = [];
config = {allowUnfree = true;};
@@ -120,6 +122,9 @@
flake-registry = "";
nix-path = config.nix.nixPath;
};
+ extraOptions = ''
+ trusted-users = root stvnliu
+ '';
channel.enable = false;
registry = lib.mapAttrs (_: flake: {inherit flake;}) flakeInputs;
nixPath = lib.mapAttrsToList (n: _: "${n}=flake:${n}") flakeInputs;
@@ -133,10 +138,7 @@
initialPassword = "stevenpassword";
isNormalUser = true;
openssh.authorizedKeys.keys = [];
- packages = with pkgs; [
- nh
- gparted
- ];
+ packages = with pkgs; [nh gparted];
extraGroups = ["wheel" "input" "networkmanager"];
};
};