aboutsummaryrefslogtreecommitdiff
path: root/common/variables.nix
diff options
context:
space:
mode:
authorZhongheng Liu <z.liu@outlook.com.gr>2024-08-21 11:48:21 +0800
committerZhongheng Liu <z.liu@outlook.com.gr>2024-08-21 11:48:21 +0800
commit793491e2a187ca8975a46be0e385891ac8a31400 (patch)
treea2c8311442669360d0f63cf7282e356b9b7ecdfa /common/variables.nix
parent4fc96a3a599b0041a3b6a4b7052d942cebf94ec2 (diff)
downloadnixos-configuration-793491e2a187ca8975a46be0e385891ac8a31400.tar.gz
nixos-configuration-793491e2a187ca8975a46be0e385891ac8a31400.tar.bz2
nixos-configuration-793491e2a187ca8975a46be0e385891ac8a31400.zip
feat: introduce flake var to shorten nh commands
Diffstat (limited to 'common/variables.nix')
-rw-r--r--common/variables.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/common/variables.nix b/common/variables.nix
index d8c3e42..189aaa7 100644
--- a/common/variables.nix
+++ b/common/variables.nix
@@ -14,6 +14,7 @@
myEmail = mkOption {type = str;};
displayScale = mkOption {type = int;};
myAutostartCommands = mkOption {type = listOf str;};
+ myConfigLocation = mkOption {type = str;};
};
# Default values for this configuration
@@ -27,5 +28,6 @@
myAutostartCommands = [
"fcitx5"
];
+ myConfigLocation = "/home/${myUserName}/nix-conf";
};
}