aboutsummaryrefslogtreecommitdiff
path: root/common/variables.nix
diff options
context:
space:
mode:
authorZhongheng Liu <z.liu@outlook.com.gr>2024-08-12 09:27:59 +0800
committerZhongheng Liu <z.liu@outlook.com.gr>2024-08-12 09:27:59 +0800
commit2fcbfd8d885fc02bcd8c3d792037695efc04cb91 (patch)
tree0f00f76a35946bb10fb23305b26397813b49e8a6 /common/variables.nix
parent28506968d7ec8df973ff4656a547c6e4af1db0bc (diff)
downloadnixos-configuration-2fcbfd8d885fc02bcd8c3d792037695efc04cb91.tar.gz
nixos-configuration-2fcbfd8d885fc02bcd8c3d792037695efc04cb91.tar.bz2
nixos-configuration-2fcbfd8d885fc02bcd8c3d792037695efc04cb91.zip
refactor: move common variables referenced into common/variables.nix
In the future, should have independent variable files for home-manager and nixos-specific, in their respective directories.
Diffstat (limited to 'common/variables.nix')
-rw-r--r--common/variables.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/common/variables.nix b/common/variables.nix
new file mode 100644
index 0000000..b3a062b
--- /dev/null
+++ b/common/variables.nix
@@ -0,0 +1,27 @@
+{
+ tmconfig,
+ pkgs,
+ lib,
+ ...
+}: {
+ # Type definitions for nix variables used in this configuration
+ options = with lib;
+ with types; {
+ myUserName = mkOption {type = str;};
+ myHostName = mkOption {type = str;};
+ myWallPaperPathString = mkOption {type = str;};
+ myDisplayName = mkOption {type = str;};
+ myEmail = mkOption {type = str;};
+ displayScale = mkOption {type = int;};
+ };
+
+ # Default values for this configuration
+ config = rec {
+ myUserName = "stvnliu";
+ myHostName = "homelab-nix";
+ displayScale = 2;
+ myWallPaperPathString = "/home/${myUserName}/wallpaper.png";
+ myDisplayName = "Zhongheng Liu";
+ myEmail = "z.liu@outlook.com.gr";
+ };
+}