aboutsummaryrefslogtreecommitdiff
path: root/common/variables.nix
diff options
context:
space:
mode:
authorZhongheng Liu <z.liu@outlook.com.gr>2024-09-19 10:24:14 +0300
committerZhongheng Liu <z.liu@outlook.com.gr>2024-09-19 10:24:14 +0300
commit09e506c6a626ea00930780ec52364cb7fd37ecd7 (patch)
tree783b78b45447d495f34870d391274a9bc7a41bc5 /common/variables.nix
parent466f0992f1f65113e1ebfdd6a9df18de666a7ae3 (diff)
downloadnixos-configuration-09e506c6a626ea00930780ec52364cb7fd37ecd7.tar.gz
nixos-configuration-09e506c6a626ea00930780ec52364cb7fd37ecd7.tar.bz2
nixos-configuration-09e506c6a626ea00930780ec52364cb7fd37ecd7.zip
feat: changes to kanshi nvidia hyprland
Bumped flake inputs to latest
Diffstat (limited to 'common/variables.nix')
-rw-r--r--common/variables.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/common/variables.nix b/common/variables.nix
index b97ff23..e8b98e2 100644
--- a/common/variables.nix
+++ b/common/variables.nix
@@ -15,6 +15,7 @@
displayScale = mkOption {type = int;};
myAutostartCommands = mkOption {type = listOf str;};
myConfigLocation = mkOption {type = str;};
+ desktopFontFullName = mkOption {type = str;};
};
# Default values for this configuration
@@ -30,6 +31,12 @@
"${pkgs.udiskie}/bin/udiskie"
"${pkgs.pa-notify}/bin/pa-notify"
];
+ specialisation."powersave".configuration = {
+ myAutostartCommands = [
+ "${pkgs.brightnessctl}/bin/brightnessctl s 64"
+ ];
+ };
myConfigLocation = "/home/${myUserName}/nix-conf";
+ desktopFontFullName = "BlexMono Nerd Font";
};
}