summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..9611e19
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,19 @@
+{ pkgs ? import <nixpkgs> { } }:
+
+with pkgs;
+
+mkShell rec {
+ nativeBuildInputs = [
+ pkg-config
+ cargo
+ rustc
+ rustfmt
+ ];
+ buildInputs = [
+ udev alsa-lib vulkan-loader
+ xorg.libX11 xorg.libXcursor xorg.libXi xorg.libXrandr # To use the x11 feature
+ libxkbcommon wayland # To use the wayland feature
+ ];
+ LD_LIBRARY_PATH = lib.makeLibraryPath buildInputs;
+ RUST_SRC_PATH = "${pkgs.rust.packages.stable.rustPlatform.rustLibSrc}";
+}