summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsteven@devbox <steven@devbox.local>2025-05-09 22:53:11 +0000
committersteven@devbox <steven@devbox.local>2025-05-09 22:53:11 +0000
commitca080c19f1f3f8e3c23a207d936d03fd5f247d12 (patch)
treea9a39f2f7f1828a46a637764b12b8aeaac653792 /CMakeLists.txt
downloadcpp-ca080c19f1f3f8e3c23a207d936d03fd5f247d12.tar.gz
cpp-ca080c19f1f3f8e3c23a207d936d03fd5f247d12.tar.bz2
cpp-ca080c19f1f3f8e3c23a207d936d03fd5f247d12.zip
init new cpp project
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..20cad24
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,9 @@
+cmake_minimum_required(VERSION 3.5)
+project(joecpp)
+add_executable(joecpp src/main.cpp)
+set(OUTPUT_DEBUG "build/debug")
+set(OUTPUT_REL "build/release")
+# Output directory for libraries in Debug configuration
+set(CMAKE_LIBRARY_OUTPUT_DIRECTORY_DEBUG ${CMAKE_BINARY_DIR}/${OUTPUT_DEBUG})
+# Output directory for libraries in Release configuration
+set(CMAKE_LIBRARY_OUTPUT_DIRECTORY_RELEASE ${CMAKE_BINARY_DIR}/${OUTPUT_REL})