aboutsummaryrefslogtreecommitdiff
path: root/nixos/services/pipewire.service.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/services/pipewire.service.nix')
-rw-r--r--nixos/services/pipewire.service.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/nixos/services/pipewire.service.nix b/nixos/services/pipewire.service.nix
index 03e82ef..be0cc76 100644
--- a/nixos/services/pipewire.service.nix
+++ b/nixos/services/pipewire.service.nix
@@ -41,6 +41,26 @@ in {
jack.enable = true;
wireplumber.configPackages = [
(pkgs.writeTextDir
+ "share/wireplumber/wireplumber.conf.d/52-profile-switch.conf" ''
+ wireplumber.settings = {
+ bluetooth.autoswitch-to-headset-profile = false
+ }
+
+ monitor.bluez.properties = {
+ ## Supported roles: hsp_hs (HSP Headset),
+ ## hsp_ag (HSP Audio Gateway),
+ ## hfp_hf (HFP Hands-Free),
+ ## hfp_ag (HFP Audio Gateway)
+ ## a2dp_sink (A2DP Audio Sink)
+ ## a2dp_source (A2DP Audio Source)
+ ## bap_sink (LE Audio Basic Audio Profile Sink)
+ ## bap_source (LE Audio Basic Audio Profile Source)
+ ## --
+ ## Only enable A2DP here and disable HFP. See note at the top as to why.
+ bluez5.roles = [ a2dp_sink a2dp_source ]
+ }
+ '')
+ (pkgs.writeTextDir
"share/wireplumber/bluetooth.lua.d/51-bluez-config.lua" ''
bluez_monitor.properties = {
["bluez5.enable-sbc-xq"] = true,