aboutsummaryrefslogtreecommitdiff
path: root/nixos/msmtp.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/msmtp.nix')
-rw-r--r--nixos/msmtp.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/nixos/msmtp.nix b/nixos/msmtp.nix
new file mode 100644
index 0000000..f5b272d
--- /dev/null
+++ b/nixos/msmtp.nix
@@ -0,0 +1,20 @@
+{
+ pkgs,
+ config,
+ ...
+}: {
+ programs.msmtp = {
+ enable = true;
+ accounts = {
+ default = {
+ auth = true;
+ tls = true;
+ # try setting `tls_starttls` to `false` if sendmail hangs
+ from = "<from address here>";
+ host = "smtp-mail.outlook.com";
+ user = "z.liu@outlook.com.gr";
+ passwordeval = "cat /secrets/smtp_password.txt";
+ };
+ };
+ };
+}