aboutsummaryrefslogtreecommitdiff
path: root/nixos/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/configuration.nix')
-rw-r--r--nixos/configuration.nix13
1 files changed, 11 insertions, 2 deletions
diff --git a/nixos/configuration.nix b/nixos/configuration.nix
index 785228a..23387c9 100644
--- a/nixos/configuration.nix
+++ b/nixos/configuration.nix
@@ -46,7 +46,15 @@
};
};
};
-
+ xdg.portal = {
+ enable = true;
+ extraPortals = with pkgs; [
+ xdg-desktop-portal-gtk
+ ];
+ config = {
+ common.default = ["gtk"];
+ };
+ };
systemd.user.services.mpris-proxy = {
description = "Mpris proxy";
after = ["network.target" "sound.target"];
@@ -74,13 +82,14 @@
];
# turned off because timedatectl doesn't like it
time.hardwareClockInLocalTime = false;
+ time.timeZone = "Europe/Athens";
services = {
#displayManager.sddm = {
# enable = true;
# wayland.enable = true;
# theme = "${import ./sddm-theme.nix {inherit pkgs;}}";
#};
- automatic-timezoned.enable = true;
+ #automatic-timezoned.enable = true;
openssh = {
enable = true;
settings = {