aboutsummaryrefslogtreecommitdiff
path: root/nixos/services/nginx.service.nix
diff options
context:
space:
mode:
authorZhongheng Liu <z.liu@outlook.com.gr>2024-12-17 00:53:10 +0200
committerZhongheng Liu <z.liu@outlook.com.gr>2024-12-17 00:53:10 +0200
commit64e476798d7bb4a93813a3f2ceed77668275fff0 (patch)
tree42c912f4e6dca3f2bebb9e27435f391d8ececce3 /nixos/services/nginx.service.nix
parent77f1155518d95c83a644eef379423c53eeb2e9c7 (diff)
downloadnixos-configuration-64e476798d7bb4a93813a3f2ceed77668275fff0.tar.gz
nixos-configuration-64e476798d7bb4a93813a3f2ceed77668275fff0.tar.bz2
nixos-configuration-64e476798d7bb4a93813a3f2ceed77668275fff0.zip
feat: experimenting with custom local hosts
Diffstat (limited to 'nixos/services/nginx.service.nix')
-rw-r--r--nixos/services/nginx.service.nix11
1 files changed, 6 insertions, 5 deletions
diff --git a/nixos/services/nginx.service.nix b/nixos/services/nginx.service.nix
index 798f078..bd8b2ef 100644
--- a/nixos/services/nginx.service.nix
+++ b/nixos/services/nginx.service.nix
@@ -1,4 +1,8 @@
-{pkgs, ...}: {
+{
+ pkgs,
+ config,
+ ...
+}: {
services.nginx = {
enable = true;
virtualHosts."localhost" = {
@@ -11,10 +15,7 @@
'';
};
};
- listenAddresses = [
- "127.0.0.1"
- "[::1]"
- ];
+ listenAddresses = ["127.0.0.1" "[::1]"];
};
};
networking.firewall.allowedTCPPorts = [80];